LISTSERV at the University of Georgia
Menubar Imagemap
Home Browse Manage Request Manuals Register
Previous (more recent) messageNext (less recent) messagePrevious (more recent) in topicNext (less recent) in topicPrevious (more recent) by same authorNext (less recent) by same authorPrevious page (November 2011, week 1)Back to main SAS-L pageJoin or leave SAS-L (or change settings)ReplyPost a new messageSearchProportional fontNon-proportional font
Date:         Fri, 4 Nov 2011 22:19:45 -0400
Reply-To:     bbser 2009 <bbser2009@GMAIL.COM>
Sender:       "SAS(r) Discussion" <SAS-L@LISTSERV.UGA.EDU>
From:         bbser 2009 <bbser2009@GMAIL.COM>
Subject:      Lost Card Question
Content-Type: text/plain; charset="us-ascii"

Hi there,

After running the code below, there was no problem for step 3, but I got the lost card information from step 4. I feel strange about this: I assume in step 3 SAS entered into the do until block twice, which in effect is similar as the step 4, thus we should have got the lost card information from step 3 as well, but we actually do not get this information.

Could anyone please say anything about this? Thank you very much.

Best regards, Max (Maaxx)

==========

data have; x=1; run;

data _null_; set have; file "c:\have.dat"; put x; run;

*step 4; data _null_; infile "c:\have.dat" end=_end; do until(_end); input x; end; run;

*step 5; data _null_; infile "c:\have.dat" end=_end; do i=1,2; input x; end; run;


Back to: Top of message | Previous page | Main SAS-L page